Ingenuity of Complete Fools

Version 0.1.4 of Coaster is here. Here is what I have added/fixed in this release:

Changes:

  • Updated libnautilus-burn wrappers to work with version >= 2.9.0.
  • Bumped gtkmm dependency to >= 2.5.5.
  • Removed dependency on bakery.
  • Moved all store transformations to within the store.
  • Added base classes to make it easy to make more layout types.
  • Implemented the tray icon instead of wrapping libegg’s version.
  • Added a progress dialog to show files that are opening.
  • Added screenshots in the help file.

Bug Fixes:

  • Checkbox issue in chooser (#158662).
  • Detachable toolbar always on (#158655).
  • Wrong rename accelerator key (#158658).
  • ISO’s deleted (#162733).
  • Unhandled exception with missing icon in gnome theme (#163188).
  • Crashes in gconf dialogs.

8 Replies to “Ingenuity of Complete Fools”

  1. Bumping dependencies to these unreleased versions of libraries a lot, will severely limit the number of people who can use it. Even people who do use gnome’s bleeding edge do not guarantee to have gtkmm 2.5..

    Good thing you removed the Bakery dependency btw, it was really slow to build and easy to have problems with it. 🙂

    Any plans to add DVD support btw, even through libnautilus-burn? PhotoCD support?

  2. This is why it is a developmental version. "Bleeding Edge"! If you want something with more sane deps. then you may wish to use a older version or wait till the stable 0.2 branch is ready.

Leave a Reply

Your email address will not be published. Required fields are marked *